Back to overview
Degraded

US Open Marketplaces Bid and Buy Issue

Feb 24 at 03:48pm EST
Affected services
US Marketplace (app.openlane.com)

Resolved
Feb 24 at 08:00pm EST

Resolved We have resolved the issue and have confirmed all bidding and buying activity going forward is working as expected. Due to the system issues, we've made the decision to extend our auction through tomorrow (Feb 25th) at 5:00pm EST. Don't worry! Your bids will be carried over - though vehicles that hit their reserve AND went into overtime were automatically sold! We apologize for any disruption to your plans 8:00pm EST

Identified We have identified an issue on the US Open Marketplace that has impacted bid and buy functions. We are working through and identifying which bids and buy actions have been impacted and are working on next steps to resolve this issue. 3:48pm EST

Created
Feb 24 at 03:48pm EST

Identified We have identified an issue on the US Open Marketplace that has impacted bid and buy activity. We are working through and identifying which bids and purchases have been impacted and are working on next steps 3:39pm EST