Back to overview

Issues with ADESA.com and ADESA.ca

May 30 at 09:31am EDT

Resolved
May 30 at 09:31am EDT

Resolved The team has resolved the issue and has confirmed the sites are working as expected. 9:47am EDT

Monitoring The team has deployed a change and are validating the sites for health. 9:43 am EDT

Identified The teams have identified the issue and are working to get this resolved as soon as able. 9:20am EDT

Investigating Teams have received reports of issues with ADESA.c and PL sites. 8:49am EDT