Back to overview
Downtime

eVIPR and Claim Case Portal Service Disruption

Mar 25, 2026 at 6:04pm UTC
Affected services
PAR North America - eVIPR
PAR Claim Case Portal

Resolved
Mar 25, 2026 at 6:17pm UTC

Resolved We have validated all service functionality is working as expected and platform stability has recovered. 2:17pm EDT

Monitoring We have restored the services and are currently validating all platforms are stable and working as expected. 2:14pm EDT

Identified We have identified an issue with our eVIPR platform and Claim Case Portal. We are working to restore services as soon as able. 2:05pm EDT

We have detected an issue with our eVIPR and Claim Case Portal services. We are working to resolve the issue as soon as able.

Updated
Mar 25, 2026 at 6:14pm UTC

Monitoring We have restored the services and are currently validating all platforms are stable and working as expected. 2:14pm EDT

Identified We have identified an issue with our eVIPR platform and Claim Case Portal. We are working to restore services as soon as able. 2:05pm EDT

We have detected an issue with our eVIPR and Claim Case Portal services. We are working to resolve the issue as soon as able.

Created
Mar 25, 2026 at 6:04pm UTC

Identified We have identified an issue with our eVIPR platform and Claim Case Portal. We are working to restore services as soon as able. 2:05pm EDT

We have detected an issue with our eVIPR and Claim Case Portal services. We are working to resolve the issue as soon as able.