Canada Open Marketplace Issues
Resolved
Mar 18, 2026 at 4:55pm UTC
Resolved We have validated the issues have been resolved and all functionality has recovered as expected. 12:55pm EDT
Monitoring We have fixed the underlying issue and are validating platform stability and all functions are working as expected. 12:44pm EDT
Identified We have identified the root cause and are working on the issue to resolve the issue as soon as able. 12:17pm EDT
Investigating We are investigating an issue with some auction statuses for 45 minute auction sale format in addition to some issues with setting floor price. We're working to resolve the issue as soon as able. 12:05pm EDT
We are investigating an issue on app.openlane.ca with some auction statuses for 45 minute auction sale format.
Affected services
Updated
Mar 18, 2026 at 4:44pm UTC
Monitoring We have fixed the underlying issue and are validating platform stability and all functions are working as expected. 12:44pm EDT
Identified We have identified the root cause and are working on the issue to resolve the issue as soon as able. 12:17pm EDT
Investigating We are investigating an issue with some auction statuses for 45 minute auction sale format in addition to some issues with setting floor price. We're working to resolve the issue as soon as able. 12:05pm EDT
We are investigating an issue on app.openlane.ca with some auction statuses for 45 minute auction sale format.
Affected services
Updated
Mar 18, 2026 at 4:17pm UTC
Identified We have identified the root cause and are working on the issue to resolve the issue as soon as able. 12:17pm EDT
Investigating We are investigating an issue with some auction statuses for 45 minute auction sale format in addition to some issues with setting floor price. We're working to resolve the issue as soon as able. 12:05pm EDT
We are investigating an issue on app.openlane.ca with some auction statuses for 45 minute auction sale format.
Affected services
Created
Mar 18, 2026 at 4:05pm UTC
Investigating We are investigating an issue with some auction statuses for 45 minute auction sale format in addition to some issues with setting floor price. We're working to resolve the issue as soon as able. 12:05pm EDT
We are investigating an issue on app.openlane.ca with some auction statuses for 45 minute auction sale format.
Affected services